Министерство цифрового развития, связи

и массовых коммуникаций Российской Федерации



Приложение №2 к приказу № 83
от 16.04.2014

Об утверждении Правил применения оборудования
систем коммутации, включая программное обеспечение, обеспечивающего выполнение установленных действий при проведении оперативно-розыскных мероприятий. Часть III. Правила применения оборудования коммутации и маршрутизации пакетов информации сетей передачи данных, включая программное обеспечение, обеспечивающего выполнение установленных действий при проведении оперативно-розыскных мероприятий

Структура документа

Приказ №83 Правила Приложение №1 Приложение №2 Приложение №3
ПРИЛОЖЕНИЕ № 2

к Правилам применения оборудования систем коммутации, включая программное обеспечение, обеспечивающего выполнение установленных действий при проведении оперативно-розыскных мероприятий. Часть III. Правила применения оборудования коммутации и маршрутизации пакетов информации сетей передачи данных, включая программное обеспечение, обеспечивающего выполнение установленных действий при проведении оперативно-розыскных мероприятий

Протокол взаимодействия технических средств ОРМ с ПУ

1. Протокол взаимодействия (обмена информацией) технических средств ОРМ с ПУ обеспечивает как управление техническими средствами ОРМ со стороны ПУ, так и передачу отобранных данных от технических средств ОРМ к ПУ, и состоит из двух протоколов:
протокола управления;
протокола передачи данных.
На логическом уровне соединение ПУ и технических средств ОРМ
реализуется в виде TCP-сессии, в качестве транспортного и сетевого протоколов используются протоколы TCP и IP.
Для управления техническими средствами ОРМ и передачи информации на ПУ используются отдельные TCP-соединения, которые называются каналом управления и каналом передачи данных, соответственно. В качестве номеров портов должны применяться номера, находящиеся вне диапазона номеров портов стандартных служб.
Подключение нескольких ПУ на один порт технического средства ОРМ не допускается.
Номер порта используемого ПУ задается при конфигурировании технических средств ОРМ. Конфигурирование и настройка технических средств ОРМ осуществляется с головного ПУ, подключенного по каналу No 0 (канал, определяемый портами 16117 и 16118).


2. Протокол управления.

2.1. Структура сообщений протокола управления. 2.1.1. Общая структура сообщений.
Сообщения протокола управления включают:
команды, передаваемые с ПУ;
ответы, передаваемые с технических средств ОРМ на ПУ и содержащие
результаты выполнения команд;
извещения, передаваемые с технических средств ОРМ на ПУ и
содержащие данные о произошедших в технических средствах ОРМ событиях (обнаружение нарушений в функционировании технических средств ОРМ, попытки несанкционированного доступа к техническим средствам ОРМ, данные об открытии/закрытии сеанса связи пользователем, а также данные о параметрах отбора и данные о параметрах серверов аутентификации);
подтверждения о получении извещения от технических средств ОРМ, передаваемые с ПУ на технические средства ОРМ.
Структура сообщений приведена на рисунке 1.
Поля Cod, Ident, Length являются служебными.
Cod – поле кода сообщения. Определяет формат и сообщения. Целочисленная переменная. Размер поля равен 1 байту.
Ident – поле идентификатора сообщения. Содержит числовое значение, используемое для установления соответствия «команда – ответ», «извещение – подтверждение». Начальное значение идентификатора в последовательности команд (извещений) устанавливается в 1 и с каждой новой командой (извещением) увеличивается на 1. Следующему за максимальным значением идентификатору присваивается значение, равное 0.
Целочисленная переменная. Размер поля равен 2 байтам.
Length – поле длины сообщения. Содержит длину всех полей сообщения (Cod, Ident, Length, Data) в байтах. Целочисленная переменная. Размер поля равен 4 байтам. Если длина сообщения превышает максимальную длину, то это сообщение воспринимается как содержащее ошибку и обрабатывается в соответствии с подпунктом 4.6 настоящего приложения.
Data – поле, содержащее значения параметров сообщения. Наличие и формат поля определяется значением поля Cod. Размер поля в байтах равен значению поля Length минус 7.

2.1.2.Структура поля данных (Data) и элементов данных (Item) сообщений.
Поле Data состоит из одного или нескольких элементов данных Item. Структура поля приведена на рисунке 2.
Элементы данных Item1, ..., ItemM содержат значения параметров команд, ответов, извещений и подтверждений.
Элементы данных могут иметь структуру одного из следующих видов:

1) Структура элементов данных Item1, ..., ItemM с полем Value фиксированной длины приведена на рисунке 3.
2) Структура элементов данных Item1, ..., ItemM с полем Value переменной длины приведена на рисунке 4.
Элементы данных Item1, ItemM с полем Value переменной длины имеют следующий формат и содержание.
Codltem - поле, содержащее код элемента данных. Целочисленная переменная. Размер поля равен 1 байту.
Lengthltem - поле, содержащее длину всех полей элемента данных, включая длину полей Codltem и Lengthltem. Целочисленная переменная. Размер поля равен 4 байтам. Наличие поля Lengthltem определяется значением поля Codltem.
Value - поле, содержащее значение параметров сообщения. Содержимое поля определяется значением поля Codltem. Размер поля Value для структуры с фиксированной длиной определяется значением поля Codltem.

2.2. Команды протокола управления.

2.2.1. Команда идентификации.
Команда идентификации передается с ПУ на технические средства ОРМ первой.

Структура команды приведена на рисунке 5.
CodCom - поле кода команды. Содержимое поля равно 1. Размер поля равен 1 байту.
IdentCom - поле идентификатора команды. Начальное значение идентификатора в последовательности команд устанавливается равным 1 и с каждой новой командой увеличивается на 1. Размер поля равен 2 байтам.
LengthCom - поле длины команды. Размер поля равен 4 байтам.

Структура элемента данных ItemLogPU, идентифицирующего ПУ, приведена на рисунке 6.
Codltem - поле кода элемента данных. Содержит сведения о текущей версии программного обеспечения ПУ или ИС БД ОРМ. Размер поля равен 1 байту.
Lengthltem - поле длины элемента данных. Размер поля равен 4 байтам.
Value - поле значения элемента данных. Содержит идентификатор ПУ или ИС БД ОРМ, подключаемого к техническим средствам ОРМ, в виде текстовой строки в ASCII кодах. Размер поля переменный.
PVersionltem - опциональный элемент данных. Размер поля равен 3 байтам. Содержит число, определяющее версию протокола обмена данными, поддерживаемого ПУ или ИС БД ОРМ.

Структура элемента PVersionltem приведена на рисунке 7.
Codltem - поле кода элемента данных. Значение равно 2. Размер поля равен 1 байту.
Value - целочисленная переменная. Размер поля равен 2 байтам. Содержит число, определяющее версию протокола обмена данными, поддерживаемого ПУ или ИС БД ОРМ. Версия текущего протокола определяется как "0".

2.2.2. Команда постановки на контроль и изменения вида контроля.
Команда постановки на контроль и изменения вида контроля предназначена для постановки на контроль по параметру отбора и для изменения вида контроля. Постановка на контроль выполняется сразу после получения этой команды. Постановка на контроль одной командой более одного объекта контроля не допускается. Для изменения вида контроля отправляется команда с существующими UCI и Ncontrol объекта. Допускается изменение значения следующих полей: Codltem, IdCon, Filter, Find.
В команде может присутствовать несколько элементов данных, соответствующих одному объекту контроля (имеющих одинаковые значения полей UCI и Ncontrol). В этом случае элементы описания данных формируют составной параметр отбора, при этом правила отбора, определенные в элементах данных, объединяются по принципу логического "И".
Структура команды постановки на контроль и изменения вида контроля приведена на рисунке 8.
CodCom - поле кода команды. Содержимое поля равно 2. Размер поля равен 1 байту.
IdentCom - поле идентификатора команды. Содержимое поля равно значению идентификатора предыдущей команды, увеличенному на 1. Размер поля равен 2 байтам.
LengthCom - поле длины команды. Размер поля равен 4 байтам.
Data - поле, содержащее элементы данных команды, состоит из подполей Item1,..., ItemM.
Item1, ..., ItemM - элементы данных команды постановки на контроль и изменения вида контроля.

Для постановки пользователя на контроль используется несколько элементов данных. Первым в команде постановки на контроль и изменения вида контроля должен быть элемент данных со значением кода элемента данных Codltem, равным 0, устанавливающий идентификационный номер контролируемого абонента (пользователя) и вид контроля. Остальные элементы, относящиеся к объекту контроля, следуют за ним.

Структура элементов данных Item1, ..., ItemM команды постановки на контроль и изменения вида контроля приведена на рисунке 9.
Codltem - поле кода элемента данных команды постановки на контроль и изменения вида контроля (код параметра отбора). Размер поля равен 1 байту.

Содержимое поля Codltem:
0 - установка идентификационного номера контролируемого абонента (пользователя) и вида его контроля;
1 - контроль по имени учетной записи пользователя - login (идентификатор объекта);
2 - контроль по телефонному номеру;
3 - контроль по адресу объекта в соответствии с IPv4 (четырехбайтовый адрес, записывается и передается по каналу в порядке, определенном спецификацией RFC791);
4 - контроль по адресу электронной почты (e-mail, в том числе Web-mail);
6 - международный идентификатор абонента сети подвижной связи (IMSI);
7 - контроль IP v4-подсети (адрес, маска (битовая маска, определяющая, какая часть IP v4 адреса узла сети относится к адресу подсети, а какая к адресу самого узла в этой подсети);
8 - контроль по уникальному идентификационному номеру службы мгновенных сообщений информационно-телекоммуникационной сети Интернет (UINICQ);
9 - контроль по адресу объекта в соответствии с IPv6 (16-ти байтовый адрес, записывается и передается по каналу в порядке, определенном спецификацией RFC1884);
10 - контроль IPv6-подсети (адрес, маска (битовая маска, определяющая, какая часть IPv6 адреса узла сети относится к адресу подсети, а какая к адресу самого узла в этой подсети);
11 - контроль по уникальному идентификатору, присваиваемому каждой единице оборудования информационно-телекоммуникационной сети "Интернет" (МАС-адресу) объекта контроля;
15 - международный идентификатор мобильного оборудования (IMEI);
18 - мобильный идентификационный номер мобильной абонентской радиостанции (MIN);
19 - контроль по унифицированному идентификатору ресурса (URI);
20 - контроль по номеру виртуальной сети VLAN (стандарт IEEE 802.1Q);
23 - контроль по диапазону номеров портов;
25 - контроль по идентификатору абонентской телефонной линии, используемому для идентификации пользователя услуг связи при доступе к сети передачи данных и телематическим услугам связи;
26 - контроль по идентификатору вызываемого и вызывающего пользователя услугами связи по передаче данных для целей передачи голосовой информации;
27 - контроль по коду прикладного протокола;
28 - контроль по полю прикладного протокола;
29 - контроль по доменному имени сервера;
30 - контроль по типу прикладного протокола;
31 - контроль по типу содержимого прикладного протокола;
32 - контроль с использованием фильтра в формате правил отбора и фильтрации трафика.

Lengthltem - поле длины элемента данных. Содержит длину всех полей элемента данных. Размер поля равен 4 байтам.
Value - поле значения элемента данных. Состоит из следующих подполей:
подполя идентификационного номера контролируемого пользователя (UCI);
подполя номера условия контроля (Ncontrol);
подполя условия контроля (IdCon);
подполя строки фильтра (Filter);
подполя строки поиска (Find).
Размер поля Value в байтах равен значению поля Lengthltem минус 5.

UCI - подполе, содержащее идентификационный номер контролируемого пользователя (абонента). Идентификационный номер отличен от нуля. Целочисленная переменная. Размер подполя равен 2 байтам.

Ncontrol - подполе, содержащее номер условия контроля. При постановке абонента на контроль или при изменении параметров его контроля, каждому условию контроля должен присваиваться уникальный номер в рамках UCI. Целочисленная переменная. Размер подполя равен 2 байтам.

IdCon - подполе условия контроля. Для подполя переменного размера перед этим подполем указывается длина подполя, равная 4 байтам. Содержимое подполя условия контроля:
а) для значения поля Codltem, равного 0:
подполе IdCon определяет вид контроля. Размер подполя равен 2 байтам.

Содержимое подполя IdCon:
0-й байт подполя IdCon:
если значение 7-го бита равно 1, то отобранные данные должны передаваться на ПУ в виде потока IP-пакетов в хронологическом порядке прохождения через точку/точки съема без предварительной обработки; при этом, если 6-ой бит 0-ого байта подполя IdCon установлен в 1, то отобранные данные должны передаваться на ПУ со всеми заголовками протоколов канального уровня, присутствующими в точке/точках съема; в противном случае отобранные данные должны передаваться на ПУ в виде IP-пакетов;
если значение 7-го бита равно 0, то для всех протоколов, использующих TCP (кроме почтовых протоколов и данных VoIP), данные должны передаваться в соответствии с форматом, определенным подпунктом 3.3.6.1 настоящего приложения; для почтовых протоколов (POP3, SMTP, IMAP) данные должны передаваться в соответствии с форматом, определенным подпунктом 3.3.7.1 настоящего приложения; для VoIP данные должны передаваться в соответствии с форматом, определенным подпунктом 3.3.6.2 настоящего приложения; все остальные данные должны передаваться в виде IP-пакетов в соответствии с подпунктом 3.3.5 настоящего приложения;
с 5 по 0-й биты - резерв, не используются и заполняются значением 0;
1-й байт подполя IdCon:
с 7 по 3-й биты - резерв, не используются и заполняются значением 0;
2-й бит - значение равно 0, если производится контроль поступающего трафика; значение равно 1, если контроль поступающего трафика не производится;
1-й бит - резерв, не используется и равен 0;
0-й бит - резерв, не используется и равен 0;
подполе NControl - значение равно 0;
пример заполнения поля IdCon с Codltem, равного 0, приведён на рисунке 10;
данные из ТС ОРМ передаются на ПУ в виде пакетов с заголовками канального уровня, производится контроль поступающего на ТС ОРМ трафика;

б) для значения поля Codltem, равного 1:
содержимое подполя IdCon - имя учетной записи пользователя; строка в ASCII кодах, содержащая идентификатор объекта - login; в имени учетной записи пользователя могут использоваться следующие служебные символы:
"*" - обозначает произвольную последовательность символов;
"?" - обозначает один произвольный символ;
размер подполя условия контроля переменный;

в) для значения поля Codltem, равного 2:
содержимое подполя IdCon - телефонный номер, каждый символ которого кодируется в ASCII коде, дополненный в конце 5-ю байтами, содержащими 0 (резерв под дальнейшие расширения); телефонный номер может содержать следующие служебные символы:
"*" обозначает произвольную последовательность символов;
"?" - обозначает один произвольный символ;
размер подполя IdCon переменный;

г) для значения поля Codltem, равного 3:
содержимое подполя IdCon - 4 байта IPv4 адреса, порядок передачи байт адреса осуществляется в соответствии с RFC791 (IPv4), порядок передачи байт адреса осуществляется в соответствии со спецификацией RFC1884(IPv6);

д) для значения поля Codltem, равного 4:
содержимое подполя IdCon - строка в ASCII кодах, содержащая контролируемый адрес электронной почты (e-mail адрес) для отбора писем, передаваемых по протоколам SMTP, POP3, IMAP4, HTTP (Web-mail); в адресе электронной почты могут использоваться следующие служебные символы:
"*" - обозначает произвольную последовательность символов;
"?" - обозначает один произвольный символ;
размер подполя условия контроля переменный;

е) для значения поля Codltem, равного 6:
содержимое подполя IdCon - строка в ASCII кодах, содержащая международный идентификатор абонента сети подвижной связи (IMSI); в IMSI могут использоваться следующие служебные символы:
"*" - обозначает произвольную последовательность символов;
"?" - обозначает один произвольный символ;
размер подполя IdCon переменный;

ж) для значения поля Codltem, равного 7:
подполе IdCon состоит из двух подполей:
подполя IP-адреса сети, содержащее IP-адрес (4 байта для IPv4, порядок передачи байт адреса осуществляется в соответствии со спецификацией RFC791 (IPv4);
подполя маска подсети, содержащее префикс подсети - количество двоичных единиц в битовой маске подсети; размер подполя равен 1 байту;

з) для значения поля Codltem, равного 8:
содержимое подполя IdCon - уникальный идентификационный номер службы мгновенных сообщений информационно-телекоммуникационной сети "Интернет" (UIN ICQ). Каждый символ номера кодируется в ASCII коде. Номер UIN ICQ содержит следующие служебные символы:
"*" - обозначает произвольную последовательность символов;
"?" - обозначает один произвольный символ;
размер подполя IdCon переменный;

и) для значения поля Codltem, равного 11:
содержимое подполя IdCon - МАС-адрес. Размер подполя равен 6 байтам;

к) для значения поля Codltem, равного 15:
содержимое подполя IdCon - строка в ASCII кодах, содержащая международный идентификатор оборудования мобильной абонентской радиостанции (IMEI). Размер подполя переменный;

л) для значения поля Codltem, равного 9:
содержимое подполя IdCon - 16 байт IPv6 адреса, порядок передачи байт адреса осуществляется в соответствии со спецификацией RFC1884(IPv6);

м) для значения поля Codltem, равного 10:
подполе IdCon состоит из двух подполей:
подполя IPv6 адреса сети, содержащие IPv6 адрес (порядок передачи байт адреса осуществляется в соответствии со спецификацией RFC1884 (IPv6)). Размер подполя равен 8 байтам;
подполя маска подсети, содержащие префикс подсети - количество двоичных единиц в битовой маске подсети. Размер подполя равен 1 байту;

н) для значения поля Codltem, равного 18:
содержимое подполя IdCon - строка в ASCII кодах, содержащая мобильный идентификационный номер мобильной абонентской радиостанции (MIN). Размер подполя переменный;

о) для значения поля Codltem, равного 19:
содержимое подполя IdCon - строка, определяющая унифицированный идентификатор ресурса URI, каждый символ которого кодируется в ASCII коде. URI может содержать следующие служебные символы:
"*" обозначает произвольную последовательность символов;
"?" обозначает один произвольный символ;
примеры:
foobar.com/index*;
baz.com/joe.php*;
размер подполя переменный;

п) для значения поля Codltem, равного 20:
строка в ASCII кодах, содержащая номер виртуальной сети. Размер поля переменный;

р) для значения поля Codltem, равного 23:
содержимое подполя IdCon - диапазон контролируемых портов;
поле состоит из 3 подполей в соответствии с рисунком 11.
Type - код транспортного протокола согласно RFC1700, размер подполя равен 4 байтам;
Min - минимальный номер порта диапазона, размер подполя равен 2 байтам;
Мах - максимальный номер порта диапазона, размер подполя равен 2 байтам;
размер поля равен 8 байтам,

с) для значения поля Codltem, равного 25:
строка в ASCII кодах, содержащая идентификатор абонентской телефонной линии, используемый для идентификации пользователя услугами связи при доступе к сети передачи данных и телематическим услугам связи; размер поля переменный;

т) для значения поля Codltem, равного 26:
строка в формате UTF-8, содержащая идентификатор вызываемого или вызывающего пользователя услугами связи по передаче данных для целей передачи голосовой информации. Могут использоваться следующие служебные символы:
* - обозначает произвольную последовательность символов;
? - обозначает один произвольный символ;
размер поля переменный;

у) для значения поля Codltem, равного 27:
содержимое подполя IdCon - код протокола прикладного уровня (равен общепринятому номеру порта, указанному в RFC1700). Целочисленная переменная, размер подполя равен 4 байтам;

ф) для значения поля Codltem, равного 28:
содержимое подполя IdCon - строка, определяющая поле прикладного протокола, название переменной и его значение, в формате "протокол.поле: значение". Допустимые значения приведены в таблице N 1.
х) для значения поля Codltem, равного 29:
содержимое подполя IdCon - строка, определяющая доменное имя ресурса (включая, но не ограничиваясь: поле host протокола HTTP, поле server name indication протокола TLS, имя сервера, передаваемое в протоколе DNS). Имя ресурса задаётся в кодировке ASCII и может содержать следующие служебные символы:
"*" обозначает произвольную последовательность символов;
"?" обозначает один произвольный символ;
примеры:
*.foobar.tv;
joe.baz.com;
размер подполя переменный;

ц) для значения поля Codltem, равного 30:
содержимое подполя IdCon - строка, идентифицирующая группу протоколов прикладного уровня:
web - протоколы передачи гипертекста (HTTP);
mail - протоколы передачи почтовых сообщений;
im - протоколы передачи мгновенных сообщений;
voip - протоколы голосовых вызовов (Voice over IP), включая RTP;
р2р - протоколы обмена файлами (BitTorrent);
name - протоколы разрешения доменных имен (DNS);
term - протоколы терминального доступа (SSH, Telnet);
encrypted - сеансовые протоколы, использующие шифрование (TLS, SSL);
размер подполя переменный;

ч) для значения поля Codltem, равного 31:
содержимое подполя IdCon - строка, определяющая MIME-тип контента (Content-Type) согласно RFC2045. Может содержать следующие служебные символы:
"*" обозначает произвольную последовательность символов;
"?" обозначает один произвольный символ;
примеры:
text/plain;
video/*;
размер подполя переменный;

ш) для значения поля Codltem, равного 32:
содержимое подполя IdCon - строка, определяющая фильтр в формате "рсар" в соответствии с приложением N 2.2 к настоящим Правилам. Размер подполя переменный.

Filter - подполе строки фильтра для условия отбора. Присутствует в случае, если значение поля Codltem элемента данных отлично от 0. Состоит из двух подполей:
подполе длины строки фильтра - целочисленная переменная. Содержит длину подполя строки фильтра. Размер подполя равен 4 байтам;
подполе строки фильтра - строка в ASCII кодах. Размер подполя переменный.
Содержимое подполя Filter должно иметь следующий формат:
[условие отбора][код протокола]:[номер порта];
условие отбора определяется символами:
= (равно) - отбирать данные;
! (восклицательный знак) - не отбирать данные.
Find - подполе строки поиска для условия отбора. Присутствует в случае, если значение поля Codltem элемента данных отлично от 0. Состоит из двух подполей:
подполя длины строки поиска - целочисленная переменная. Содержит длину подполя строки поиска. Размер подполя равен 4 байтам;
подполя строки поиска - строка в ASCII кодах. Размер подполя переменный;
в поле Find допускается занесение последовательности произвольных байт, поиск которой должен осуществляться в потоке данных.

2.2.3. Команда снятия с контроля.
Снятие с контроля выполняется после получения команды. Снятие с контроля более одного объекта контроля одной командой не допускается. Структура команды снятия с контроля приведена на рисунке 12.
CodCom - поле кода команды. Содержимое поля равно 3. Размер поля равен 1 байту.
IdentCom - поле идентификатора команды. Содержимое поля равно значению идентификатора предыдущей команды, увеличенному на 1. Размер поля равен 2 байтам.
LengthCom - поле длины команды. Размер поля равен 4 байтам.
Data - поле, содержащее элементы данных команды, состоит из подполей Iteml, ..., ItemM.
Item1, ..., ItemM - элементы данных команды снятия с контроля.

Структура элементов данных Item1, ..., ItemM команды снятия с контроля приведена на рисунке 13.
Codltem - поле кода элемента данных. Содержимое поля равно 1. Размер поля равен 1 байту.
Value - поле значения элемента данных. Состоит из двух подполей: идентификационного номера контролируемого пользователя (UCI) и номера условия контроля (Ncontrol).
UCI - подполе, содержащее идентификационный номер контролируемого пользователя (абонента). Целочисленная переменная. Размер подполя равен 2 байтам.
Ncontrol - подполе, содержащее номер условия контроля. Используется совместно с UCI для полного снятия пользователя с контроля (при этом значение подполя Ncontrol равно 65535), либо для снятия пользователя по отдельному виду контроля. Целочисленная переменная. Размер подполя равен 2 байтам.

2.2.4. Команда проверки работоспособности канала связи с ПУ и состояния ТС ОРМ.
Команда используется для проверки работоспособности канала связи с ПУ и состояния ТС ОРМ, при отсутствии передачи сообщений по каналу управления. Период посылки команды устанавливается при инсталляции ТС ОРМ и по умолчанию составляет 5 минут. Структура команды приведена на рисунке 14.
CodCom - поле кода команды. Содержимое поля равно 4. Размер поля равен 1 байту.
IdentCom - поле идентификатора команды. Содержимое поля равно значению идентификатора предыдущей команды, увеличенному на 1. Размер поля равен 2 байтам.

2.2.5. Команда запроса времени.
Команда обеспечивает запрос текущего системного времени ТС ОРМ. После установления канала управления между техническими средствами ОРМ и ПУ и получения ответа на команду идентификации, команда запроса времени передается с ПУ в любой момент времени. Структура команды приведена на рисунке 15.
CodCom - поле кода команды. Содержимое поля равно 5. Размер поля равен 1 байту.
IdentCom - поле идентификатора команды. Содержимое поля равно значению идентификатора предыдущей команды, увеличенному на 1. Размер поля равен 2 байтам.

2.2.6. Команда коррекции системного времени.
Команда обеспечивает коррекцию системного времени в ТС ОРМ и выдается с ПУ, подключенного по каналу "0", в любой момент времени после установления канала управления "технические средства ОРМ - ПУ". Структура команды приведена на рисунке 16.
CodCom - поле кода команды. Содержимое поля равно 6. Размер поля равен 1 байту.
IdentCom - поле идентификатора команды. Содержимое поля равно значению идентификатора предыдущей команды, увеличенному на 1. Размер поля равен 2 байтам.
Data - поле, содержащее элемент данных команды, состоит из элемента CorrectAT.

Структура элемента данных CorrectAT команды коррекции системного времени приведена на рисунке 17.
Codltem - поле кода элемента данных: Содержимое поля равно 1. Размер поля равен 1 байту.
Value - поле значения элемента данных. Содержит значение "+/-" в секундах от текущего значения системного времени в ТС ОРМ. Целочисленная переменная со знаком. Размер поля равен 4 байтам.

2.2.7. Команда рестарт.
Команда передается с головного ПУ, подключенного по каналу "0", и используется для уничтожения всех содержащихся в ТСах ОРМ данных о параметрах отбора информации и перевода ТС ОРМ в начальное состояние (ожидание команды идентификации). При этом TCP-соединение не разрывается. Структура команды приведена на рисунке 18.
CodCom - поле кода команды. Содержимое поля равно 7. Размер поля равен 1 байту.
IdentCom - поле идентификатора команды. Содержимое поля равно значению идентификатора предыдущей команды, увеличенному на 1. Размер поля равен 2 байтам.

2.2.8. Команда включения передачи извещений со статистическими данными.
Команда используется для включения режима передачи извещений, содержащих статистические данные протоколов "RADIUS", "TACACS+", "Diameter" и "GTP-С".

Структура команды приведена на рисунке 19.
CodCom - поле кода команды. Содержимое поля равно 10. Размер поля равен 1 байту.
IdentCom - поле идентификатора команды. Содержимое поля равно значению идентификатора предыдущей команды, увеличенному на 1. Размер поля равен 2 байтам.

2.2.9. Команда выключения передачи извещений со статистическими данными.
Команда используется для выключения режима передачи извещений, содержащих статистические данные протоколов "RADIUS", "TACACS+", "Diameter" и "GTP-С".

Структура команды приведена на рисунке 20.
CodCom - поле кода команды. Содержимое поля равно 11. Размер поля равен 1 байту.
IdentCom - поле идентификатора команды. Содержимое поля равно значению идентификатора предыдущей команды, увеличенному на 1. Размер поля равен 2 байтам.

2.2.10. Команда запроса загрузки сети и ТС ОРМ.
Команда используется для запроса передачи с ТС ОРМ статистических сведений о количестве принятых техническим средством ОРМ пакетов данных и об объеме оставшейся свободной памяти этого технического средства ОРМ. Структура команды приведена на рисунке 21.
CodCom - поле кода команды. Содержимое поля равно 12. Размер поля равен 1 байту.
IdentCom - поле идентификатора команды. Содержимое поля равно значению идентификатора предыдущей команды, увеличенному на 1. Размер поля равен 2 байтам.

2.2.11. Команда удаленного выключения ТС ОРМ.
Команда используется для удаленного выключения ТС ОРМ. Указанная команда поступает от головного ПУ, подключенного по каналу "0". По данной команде технические средства ОРМ должны уничтожить все данные о параметрах отбора, направить ответ на ПУ, а затем произвести самовыключение. Структура команды приведена на рисунке 22.
CodCom - поле кода команды. Содержимое поля равно 13. Размер поля равен 1 байту.
IdentCom - поле идентификатора команды. Содержимое поля равно значению идентификатора предыдущей команды, увеличенному на 1. Размер поля равен 2 байтам.

2.2.12. Команда установки параметров сервера аутентификации.
Данной командой производится настройка ТС ОРМ на конкретный сервер аутентификации оператора связи. Структура команды приведена на рисунке 23.
CodCom - поле кода команды. Содержимое поля равно 16. Размер поля равен 1 байту.
IdentCom - поле идентификатора команды. Содержимое поля равно значению идентификатора предыдущей команды, увеличенному на 1. Размер поля равен 2 байтам.
LengthCom - поле длины команды. Размер поля равен 4 байтам.
Data - поле, содержащее элемент данных команды, состоит из элемента ItemAServer.
ItemAServer - элемент данных, содержащий параметры сервера аутентификации.
Структура элемента данных ItemAServer приведена на рисунке 24.
Codltem - поле кода элемента данных. Размер поля равен 1 байту. Содержимое поля:
0 - сервер аутентификации Radius IPv4;
1 - сервер аутентификации Radius IPv6;
2 - сервер аутентификации Tacacs+ IPv4;
3 - сервер аутентификации Tacacs+ IPv6;
4 - сервер аутентификации Diameter IPv4;
5 - сервер аутентификации Diameter IPv6.
Lengthltem - поле длины элемента данных. Содержит длину всех полей элемента данных. Размер поля равен 4 байтам.
Value - поле значения элемента данных. Состоит из четырех подполей:
IP_Aserver - подполе IP-адреса сервера аутентификации. Для значений поля Codltem равных 0, 2, 4 подполе содержит IPv4 адрес сервера аутентификации. Порядок передачи байт адреса осуществляется в соответствии со спецификацией RFC791. Размер подполя IP_Aserver равен 4 байтам. Для значений поля Codltem равных 1, 3, 5 подполе содержит IPv6 адрес сервера аутентификации. Порядок передачи байт адреса осуществляется в соответствии со спецификацией RFC1884 (IPv6). Размер подполя IP Aserver равен 16 байтам;
Port1 - подполе порта 1 сервера аутентификации. Размер подполя равен 2 байтам;
Port2 - подполе порта 2 сервера аутентификации, для значения поля Codltem, равного 2, 3, 4, 5, подполе отсутствует. Размер подполя равен 2 байтам;
Key - подполе ключа шифрования идентификатора. Для значения Codltem, равного 0, 1, 4, 5 подполе отсутствует. Для значения поля Codltem, равного 2 и 3, подполе содержит ключ шифрования идентификатора пользователя (абонента). Значение передается в ASCII кодах. Размер подполя переменный.

2.2.13. Команда удаления параметров сервера аутентификации.
Данной командой производится удаление параметров настройки ТС ОРМ на конкретный сервер аутентификации оператора связи.
Структура команды приведена на рисунке 25.
CodCom - поле кода команды. Содержимое поля равно 17. Размер поля равен 1 байту.
IdentCom - поле идентификатора команды. Содержимое поля равно значению идентификатора предыдущей команды, увеличенному на 1. Размер поля равен 2 байтам.
LengthCom - поле длины команды. Размер поля равен 4 байтам.
Data - поле, содержащее элемент данных команды, состоит из элемента ItemAServer.
ItemAServer - элемент данных, содержащий параметры сервера аутентификации.
Структура элемента данных ItemAServer приведена на рисунке 26.